"Impossible travel" alerts from Microsoft in the DK region

Incident Report for Keepit

Update

We are continuing to investigate this issue.
Posted May 16, 2025 - 21:14 UTC

Update

We are continuing to investigate this issue. Next update 17:00 GMT
Posted May 15, 2025 - 19:03 UTC

Investigating

A small number of customers in the DK-CO region have reported receiving "impossible travel" alerts from Microsoft for mailboxes that are included in a running Keepit backup connector. We are working with Microsoft to investigate these reports and determine a root cause. Next update 18:00 GMT
Posted May 15, 2025 - 06:16 UTC