Microsoft Teams Chat Backups Failing for Some Users

Incident Report for Keepit

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 13:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2026 - 19:24 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 15, 2026 - 13:46 UTC

Investigating

We have identified an issue affecting Microsoft Teams Chat backups for some users in multiple regions following a recent update.
The rollout has been paused while we investigate and implement a fix. Our team is actively working to resolve the issue while identifying the root cause.
Next update in 90 minutes.
Posted Apr 15, 2026 - 09:44 UTC
This incident affected: Australia, Sydney (au-sy) (SaaS Backup), Canada, Toronto (ca-tr) (SaaS Backup), and Switzerland, Zurich (ch-zh) (SaaS Backup).