Late jobs

Incident Report for Keepit

Resolved

This incident has been resolved.
Posted Sep 22, 2023 - 20:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2023 - 14:28 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 22, 2023 - 07:21 UTC

Investigating

Some regions are experiencing late jobs. We are working to resolve the issue and will update the status page as soon as the issue is resolved
Posted Sep 21, 2023 - 21:23 UTC
This incident affected: United States, Washington DC (us-dc) (SaaS Backup) and Germany, Frankfurt (de-fr) (SaaS Backup).