The fix has been successfully deployed across all environments. After a period of monitoring, no performance issues have been observed. The incident is now considered resolved and will be closed
Posted Aug 26, 2025 - 18:10 UTC
Monitoring
Keepit has successfully deployed the fix across all environments. The Keepit for Google Workspace application is now fully operational, and Customers can continue using the service without any disruptions. We will continue to closely monitor performance to ensure full stability
Posted Aug 22, 2025 - 13:44 UTC
Update
Following collaboration with Google, the Keepit for Google Workspace application is now available again on the Google Workspace Marketplace. Keepit is preparing a hotfix to restore full functionality. After the hotfix is released, the restore of scripts in native format will be temporarily unavailable, while all other restore capabilities will remain fully operational. Backup of scripts continues as expected, and only the restore in native format is affected. Keepit will continue to work on restoring support for scripts in their native format and will provide updates as progress is made
Posted Aug 21, 2025 - 19:30 UTC
Update
The Keepit for Google Workspace application remains under review by Google’s Trust & Safety Team as part of their extended verification process. We are in direct contact with the Google Cloud Team to address all outstanding requirements and work toward having the application re-listed on the Google Workspace Marketplace as quickly as possible
Posted Aug 11, 2025 - 14:10 UTC
Update
The Keepit for Google Workspace app is still undergoing Google’s extended review process. Our team is working closely with the Google Cloud Team to address all outstanding points and ensure the app is re-listed on the Google Workspace Marketplace at the earliest opportunity. Thank you for your continued patience and support as we work toward a resolution
Posted Aug 08, 2025 - 10:51 UTC
Update
The Keepit for Google Workspace application remains under review by Google’s Trust and Safety Team as part of their extended verification process. We are in ongoing direct contact with Google to address their requirements and are actively working to have the app re-listed on the Marketplace as soon as possible. We appreciate your continued patience and understanding during this time
Posted Aug 06, 2025 - 10:10 UTC
Update
Due to additional requirements from Google’s Trust and Safety Team, the verification of "Keepit for Google Workspace" application is still underway. We are in the final stages of the Google verification process. This is a top priority for our team, which is actively collaborating with Google to resolve the issue and restore availability as soon as possible. We appreciate your patience and understanding
Posted Aug 01, 2025 - 21:10 UTC
Update
We're continuing to work with Google to complete their extended verification process and return the Keepit app to the Google Workspace Marketplace
Posted Jul 30, 2025 - 11:43 UTC
Identified
As part of an upcoming upgrade to the Keepit connector for Google Workspace, we uploaded a new version of the Keepit app for Google Workspace to the Google Workspace Marketplace. This triggered Google's normal automated review process. The automated process encountered several unusual verification errors not related to our code change, and we're working with Google staff to resolve them. Until Google is able to resolve them, users who do not have a pre-existing Google Workspace connector cannot add a new one. We will provide updates as Google updates us, but because of the nature of their support processes, we can't provide an exact timeline