Search import delays in UK region

Incident Report for Keepit

Monitoring

A fix has been implemented and we are monitoring the results
Posted Mar 12, 2026 - 20:24 UTC

Identified

The issue has been identified and a fix is being implemented
Posted Mar 12, 2026 - 10:09 UTC

Investigating

The United Kingdom (UK-LD) region is experiencing delays in indexing. We are working to resolve the issue and will update the status page as soon as it is resolved
Posted Mar 11, 2026 - 09:59 UTC