Internal network issue
Incident Report for Keepit
Resolved
This incident has been resolved.
Posted Jun 21, 2020 - 17:08 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2020 - 17:35 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 20, 2020 - 17:26 CEST
Investigating
An internal networking issue against our EU region caused preventing access to the user interface - we are working on a solution.
Posted Jun 20, 2020 - 16:12 CEST
This incident affected: EU (User Interface).