Frankfurt Datacenter Connectivity Disruption

Incident Report for Keepit

Resolved

This incident has been resolved.
Posted May 05, 2026 - 15:46 UTC

Monitoring

We have experienced a disruption with our Frankfurt datacenter connectivity.
The root cause has been identified, and we have mitigated the issue. We will continue to monitor the situation until a permanent fix is in place
Posted May 05, 2026 - 11:23 UTC