Failures of backup jobs

Incident Report for Keepit

Resolved

Backup jobs are now performing well.
Posted Oct 02, 2023 - 19:13 UTC

Investigating

Some backup jobs in the US region are failing. We investigate the issue and will provide updates shortly
Posted Oct 02, 2023 - 18:00 UTC
This incident affected: United States, Washington DC (us-dc) (SaaS Backup).