Support Email Delivery Problems
Incident Report for Keepit
Resolved
This incident has been resolved.
Posted Apr 13, 2024 - 08:02 UTC
Investigating
The Keepit Support system is currently experiencing problems with email delivery - this may cause delays and problems in communication. The matter is under investigation.
Posted Apr 13, 2024 - 00:30 UTC