Connectivity issues in the US region

Incident Report for Keepit

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 08:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2025 - 14:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 22, 2025 - 07:03 UTC

Investigating

We are seeing problems with login and are investigating the issue
Posted Apr 21, 2025 - 14:14 UTC
This incident affected: United States, Washington DC (us-dc) (User Interface, API).