User access issues on US environment

Incident Report for Keepit

Update

We are continuing to monitor for any further issues.
Posted May 26, 2025 - 14:19 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 23, 2025 - 14:23 UTC

Update

We are continuing to investigate this issue.
Posted May 23, 2025 - 09:04 UTC

Update

We are continuing to investigate this issue.
Posted May 23, 2025 - 07:00 UTC

Investigating

We are currently experiencing an outage affecting user interface access in the US region. Our team is actively investigating the issue, and we will provide updates as more information becomes available
Posted May 23, 2025 - 05:29 UTC
This incident affects: United States, Washington DC (us-dc) (User Interface, API).