Backup delays
Incident Report for Keepit
Resolved
Post maintenance database issue has fixed.
Posted May 24, 2020 - 11:59 UTC
Monitoring
Some backup delays are expected on the EU environment due to post maintenance database issues. We are following the performance of the environment closely
Posted May 22, 2020 - 08:39 UTC
This incident affected: Denmark, Copenhagen (dk-co) (SaaS Backup).