Search import delays in DE region

Incident Report for Keepit

Update

We are continuing to investigate this issue.
Posted 28 days ago. Jun 02, 2025 - 13:31 UTC

Investigating

The Germany (DE-FR) region is experiencing delays in indexing. We are working to resolve the issue and will update the status page as soon as it is resolved
Posted 1 month ago. May 29, 2025 - 10:46 UTC