o365 performance impacting backup
Incident Report for Keepit
Resolved
We are not seeing Covid-related capacity issues from external parties any longer
Posted Jul 03, 2020 - 09:54 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 26, 2020 - 08:52 UTC
Monitoring
Due to the current Covid-19 situation, the o365 cloud platform is experiencing an unprecedented uptake and growth in demand. This has led to certain limitations being implemented on the platform in order to restrict or limit resource consumption.

For customers backing up their o365 data, they may notice that backups run slower than usual or are even late. This is not due to capacity issues on the Keepit platform, this is simply due to restrictions put in place on the o365 platform to ensure reasonable access for all customers.

We are making some adjustments to our systems in order to better deal with this unusual situation and we will continue to monitor the development the coming weeks.
Posted Mar 26, 2020 - 08:50 UTC
This incident affected: Denmark, Copenhagen (dk-co) (SaaS Backup), United States, Washington DC (us-dc) (SaaS Backup), and Australia, Sydney (au-sy) (SaaS Backup).