Investigating — Microsoft Graph Synchronization Errors for New Connectors

Incident Report for Keepit

Investigating

Following our earlier resolution update, customers have reported that the issue persists. We have confirmed this and are actively investigating in collaboration with Microsoft, whose fix appears to not yet be fully deployed.
We will provide a further update as soon as we have confirmation from Microsoft.
Posted Aug 21, 2026 - 19:06 UTC
This incident affects: Denmark, Copenhagen (dk-co) (SaaS Backup), United States, Washington DC (us-dc) (SaaS Backup), Australia, Sydney (au-sy) (SaaS Backup), United Kingdom, London (uk-ld) (SaaS Backup), Germany, Frankfurt (de-fr) (SaaS Backup), Canada, Toronto (ca-tr) (SaaS Backup), and Switzerland, Zurich (ch-zh) (SaaS Backup).