Connectivity issues with uk-ld.keepit.com
Incident Report for Keepit
Resolved
The intermittent network issue has been resolved and all systems are now operational again.
Posted Nov 14, 2022 - 12:49 CET
Investigating
Customers might see problems getting to https://uk-ld.keepit.com - we are investigating this network issue.
Posted Nov 14, 2022 - 12:35 CET
This incident affected: United Kingdom, London (uk-ld) (User Interface, API).