Delay in Support response due to a technical issue
Incident Report for Keepit
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 08:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2024 - 15:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2024 - 14:05 UTC
Investigating
Due to an ongoing issue, customers may experience delays in receiving responses to support tickets on the platform. We apologize for the inconvenience and are working to resolve it as quickly as possible
Posted Nov 18, 2024 - 11:20 UTC